High error rates when accessing Analytics on Branch Dashboard
Incident Report for Branch
Resolved
This issue is now resolved and Analytics on the Branch dashboard is now working as expected.
Posted Oct 30, 2020 - 05:16 PDT
Investigating
We are experiencing high error rates while trying to load analytics on the Branch Dashboard. Our Engineering team is investigating this issue.
Posted Oct 30, 2020 - 04:19 PDT
This incident affected: Dashboard.