Higher error rates and latency on API gateway
Incident Report for Branch
Resolved
Pageviews, V1 Events, and Journeys have recovered. Service rates have returned to normal levels and we will continue to actively monitor.
Posted Apr 05, 2020 - 13:19 PDT
Identified
Primary API is back online as of 11.30 PT. We are still seeing errors with the legacy API which is impacting pageview, V1/event and Journeys. We continue to investigate this issue.
Posted Apr 05, 2020 - 12:05 PDT
Update
We are continuing to investigate this issue.
Posted Apr 05, 2020 - 11:01 PDT
Investigating
As of about 10:00 AM PT, we began to face high error rates and latency on our main API gateway which is causing high error rates across all API endpoints that talk to api2.branch.io. This would affect ALL event metrics, SDK APIs, and Journeys rendering.Link redirection itself is unaffected, but deep link resolution inside the app would fail.
Posted Apr 05, 2020 - 10:51 PDT
This incident affected: API.