Link Redirection Errors
Incident Report for Branch
Resolved
Link redirection has returned to normal as of 6:44 pm, PDT.
Posted 6 months ago. Jun 13, 2018 - 18:46 PDT
Identified
Link redirection began experiencing issues at 6:21 pm PDT. Our team is investigating.
Posted 6 months ago. Jun 13, 2018 - 18:34 PDT
This incident affected: Link Redirection.