Delayed Dashboard Reports
Incident Report for Branch
Resolved
Our team deployed a fix at 12:02 pm PST, and dashboard report latency has returned to normal.
Posted 5 months ago. Mar 06, 2019 - 12:23 PST
Investigating
Beginning at around 9 am PST, we began experiencing intermittent delays in some of the analytics data displayed on our dashboard.

Our team is investigating and will provide updates here as we learn more.
Posted 5 months ago. Mar 06, 2019 - 11:00 PST
This incident affected: Dashboard.