SDK API connectivity issues
Incident Report for Branch
Resolved
All iOS SDK traffic has been restored to normal. Between the windows of 4:00PM and 6:07PM, all traffic coming from iOS SDKs which leverage certificate pinning would have failed to connect to our APIs. Our Engineering team is now working to ensure all our certificates are up to date, and correctly compatible with the pinning features enabled on the newer versions of the iOS SDK. It would appear this would haver also briefly impacted connectivity on Android SDKs (only Android v3.0.0+) between 5:30pm - 6:07PM. As of 6:07PM PST all service was restored to normal.
Posted 14 days ago. Dec 04, 2018 - 18:07 PST
Investigating
Starting at 4:00pm PT, iOS SDK traffic to the Branch SDK began to fail due to certificate pinning errors. The certificate issues have been restored and all traffic should be restored to normal as of 5:35pm PT. During this time window iOS SDKs would have been unable to reach the API due to SSL errors. No other systems were impacted during this time. We are continuing to monitor the situation.
Posted 14 days ago. Dec 04, 2018 - 17:39 PST
This incident affected: API.