Links dashboard creation issue

Incident Report for Branch

Resolved

We have identified the issue scope and narrowed down to a rare edge case
Posted Apr 19, 2022 - 12:34 PDT

Investigating

We are aware of an issue with creating and updating links via our dashboard. The team is actively investigating and working towards a fix.
Posted Apr 19, 2022 - 12:22 PDT