Unable to create or clone Journeys

Incident Report for Branch

Resolved

As of 08:36 PM Pacific Time, we have restored the Journey services. You should now be able to create and clone Journeys successfully.
Posted Aug 06, 2025 - 22:21 PDT

Investigating

At 8:20 PM Pacific Time, we identified an issue with not being able to create or clone Journeys. Our Engineering teams are investigating the issue.
Posted Aug 06, 2025 - 20:44 PDT
This incident affected: Journeys.