Increase in error responses from Sendgrid ESP
Incident Report for Branch
Resolved
On July 27, 2023, at 11:30 am PT, our Engineering monitoring alerted that there were issues concerning SendGrid and Braze+SendGrid Universal Email integrations. We immediately began investigating the incident and determined that this was not an issue within the Branch platform, but with the underlying Email Service Sender, SendGrid/Twilio. We reported the issue to SendGrid/Twilio and have been in communication with them. During the incident window, some deep links were not redirecting as intended, but would have redirected to the app-level desktop fallback if configured so end-customers would have seen limited errors. As of 10 am PT on July 28, 2023, both the Branch, Braze, and SendGrid teams are unable to reproduce this issue. To ensure a comprehensive resolution, we have formally escalated this matter with SendGrid/Twilio, and we are awaiting additional information about the incident from them. We will be sharing additional information as soon as possible.
Posted Jul 28, 2023 - 12:26 PDT
Monitoring
As of 10 am PT on 6/28, it appears latency is better on the SendGrid side.
Posted Jul 28, 2023 - 10:25 PDT
Investigating
As of 9:03 am PST we are once again seeing an increase in error responses for Universal Email Campaign links for clients integrated Sendgrid services, this includes those using Sendgrid, Braze + Sendgrid ESPs. We have reported this issue to Sendgrid and will continue to work with them to resolution.
Posted Jul 28, 2023 - 09:18 PDT
This incident affected: Deep Linking.