Universal Email Services Degraded
Incident Report for Branch
Resolved
We identified the issue with network configurations and Universal Email Services have now been restored.
Posted Jul 31, 2024 - 06:52 PDT
Update
We identified the issue with network configurations and Universal Email Services have now been restored.
Posted Jul 31, 2024 - 06:50 PDT
Investigating
As of 4 AM PT, we started to see high error rates with redirection of Universal Email Links, resulting in links not accessible. Engineering Team is investigating.
Posted Jul 31, 2024 - 06:40 PDT
This incident affected: Link Redirection.