High Latency on Error rates

Incident Report for Branch

Resolved

Our team was able to apply fixes and all systems have fully recovered as of 9:30 AM PT.
Posted Feb 13, 2023 - 09:51 PST

Investigating

SInce 8:45 AM PT we are experiencing high latency and error rates on the Branch API. Our Engineering team is actively investigating this issue.
Posted Feb 13, 2023 - 09:22 PST
This incident affected: API and Link Redirection.