Links Issue
Incident Report for Branch
Resolved
Link service has remained stable and the issue is resolved.
Posted Feb 23, 2020 - 09:05 PST
Monitoring
Link service has been restored. Investigation into root cause is ongoing.
Posted Feb 23, 2020 - 08:26 PST
Investigating
As of 7:45am PT some links are encountering issues, and returning an error. We are actively investigating.
Posted Feb 23, 2020 - 08:09 PST
This incident affected: Link Redirection.