Google Ads iOS attribution pipeline

Incident Report for Branch

Resolved

Our team has now pushed a fix to resolve the issue. We are assessing impact and will follow up with more details.
Posted Sep 08, 2025 - 18:14 PDT

Identified

We have identified an issue with Google Ads iOS attribution pipeline impacting partial attribution data beginning July 23rd. We are working to resolve the issue and assess impact.
Posted Sep 08, 2025 - 16:04 PDT