Cohort Analytics Service Unavailable

Incident Report for Branch

Resolved

Cohort Analytics service is now up and working
Posted Mar 18, 2025 - 09:05 PDT

Investigating

We are currently investigating an issue with Cohort Analytics being unavailable. You will see a message "No analytics found". Our teams are currently investigating.
Posted Mar 18, 2025 - 03:37 PDT