Links issue
Incident Report for Branch
Resolved
Our engineers have now resolved the issue. Since 7:55am, link redirection is working as expected and error rates and latency have returned to normal.
Posted Feb 21, 2024 - 08:29 PST
Investigating
As of 5:35am PST we are investigating an issue with links and link redirection
Posted Feb 21, 2024 - 08:05 PST
This incident affected: Link Redirection.