iOS 9.3.1 broke large apple-app-site-association files
Incident Report for Branch
Resolved
This incident has been resolved.
Posted over 3 years ago. May 13, 2016 - 09:47 PDT
Monitoring
We're responding to a temporary change to Universal Link behavior as a result of Apple’s latest update - iOS 9.3.1.

BACKGROUND

As you may know, iOS 9.3 broke Universal Links for a very small number of apps. As a result, Apple hastily pushed a fix, iOS 9.3.1. In iOS 9.3.1 they implemented a silent change that had a downstream impact on Universal Links using the bnc.lt domain. Apple added a size limit of 128kb to the size of the apple-app-site-association (AASA) file that is used to validate Universal Links. Unfortunately, Apple did not warn developers that this restriction would be put in place.

Our existing AASA file was approximately 500kb (before compressing). The AASA had been tested extensively and had not seen any problems until iOS 9.3.1.

Our engineering team became aware of the change and immediately pushed a fix to reduce the size of the AASA file.

IMPACT

Links will still function as normal in most respects, except for some cases where Universal Link behavior is impacted.

**TEST APPS**

Test app that use bnc.lt will not have Universal Links available until we are able to push a larger fix that keeps the apple-app-site-association file small.

**For Branch apps that have not set up a custom domain:**

Users who upgraded to iOS 9.3.1 before April 4th 10:30am PST will see non-Universal Link behavior (the redirect to the app’s App Store page or designated mobile web fallback) when bnc.lt links are clicked.

This behavior will continue until Apple re-scrapes the updated AASA file. Based on experience we know it happens anytime an app is reinstalled/updated from the App Store. It is also possible that Apple automatically re-scrapes the AASA file at certain time intervals, but there is no documentation to confirm this.

**For Branch apps that use a custom domain:**

Links that use a custom domain were not impacted by this change.

If you are using links on the bnc.lt domain (even though you have a custom domain set up in the dashboard), users who click a bnc.lt link on iOS 9.3.1 will see non-Universal Link behavior indefinitely. We recommend only using links with your custom domain.

LOOKING FORWARD

We are working on a long-term solution to allow apps with custom domains to still make use of a Branch-provided domain like bnc.lt. We will also continue to ensure that developers who do not have their own custom domain will not be subject to problems due to the size of the AASA file.

As always, we will respond quickly to changes to ensure that your deep links work as smoothly as possible. Write in to support@branch.io with questions.
Posted over 3 years ago. Apr 05, 2016 - 15:36 PDT