Branch Dashboard is Inaccessible
Incident Report for Branch
Resolved
The dashboard was down due to our internal infrastructure issues. The problem was quickly identified and resolved to minimize the customer inconvenience. Our team will take more action items to prevent this type of incident in the future.
Posted Oct 13, 2022 - 01:22 PDT
Investigating
Since 12 AM PT, we are observing an issue with our Dashboard Service. Users might face an error while trying to access the Branch Dashboard. Our Engineering Teams are actively Investigating.
Posted Oct 13, 2022 - 00:32 PDT
This incident affected: Dashboard.