SSO login error
Incident Report for Branch
Resolved
Dashboard login should once again be working. No data or link redirects were affected.
Posted Nov 20, 2023 - 16:11 PST
Identified
The engineering team has identified the issue and is now rolling out a fix.
Posted Nov 20, 2023 - 13:55 PST
Investigating
We have identified an issue with login, our engineers are currently investigating.
Posted Nov 20, 2023 - 13:32 PST
This incident affected: Dashboard.