Major Service Outage [8:55am - 9:15am PT]
Incident Report for Branch
Resolved
As of ~9:15am PT, all service has been restored but we are still monitoring for any unexpected behavior.
Posted 4 months ago. Aug 06, 2018 - 09:47 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Aug 06, 2018 - 09:46 PDT
Investigating
The Branch Engineering team was alerted on a major system outage which was impacting all our public facing components (Dashboard, Links, APIs). During this time our system was not accepting or handling any requests which severely impacted all our customers. Our team found a failing centralized authentication component that, despite having sufficient capacity and redundancy, caused this cascading service failure. As of about 9:15am PT all systems have been restored to regular service. We're conducting a further investigation and evaluation and will update this post accordingly.

At this moment, we've verifying all our critical, and then non-critical systems are 100% healthy in addition to investigating this failed component. If you have any questions or observe unexpected product behavior, please write in to Technical Account Manager team, or support@branch.io, or @BranchDevTeam on Twitter and we'll respond back as soon as possible. Thank you.
Posted 4 months ago. Aug 06, 2018 - 09:46 PDT
This incident affected: API, Dashboard, Link Redirection, Deep Linking, and Export API.