Dashboard access

Incident Report for Branch

Resolved

Our Engineering Teams have fixed the issue, Dashboard is now accessible. No data was impacted and the incident has been resolved.
Posted Jan 09, 2023 - 09:12 PST

Investigating

We are currently aware of an issue with accessing the Branch Dashboard. We are actively looking into it.
Posted Jan 09, 2023 - 09:01 PST
This incident affected: Dashboard.