Daily Exports delayed by a few hours for 2/2
Incident Report for Branch
Resolved
All files for the 2/2 UTC day have been completed. We apologize if your exports were delayed. We've added additional monitoring and alerting, and we will be manually monitoring these systems for the foreseeable future.
Posted Feb 03, 2020 - 17:45 PST
Identified
Some customers will experience a delay in the availability of CSV files for the 2/2 UTC day. Alerting proactively notified us of the issue and we began generating CSVs immediately. However, some files will not be ready by our stated SLA (per https://docs.branch.io/exports/daily-exports/#response). We are working hard to add additional monitoring so we can detect issues even earlier.

Relatedly, we are encouraging our customers to investigate using our Custom Export API (https://docs.branch.io/exports/custom-exports). This allows customers to dynamically generate files, choosing time zone, columns and filters. You can thus download data within a couple of hours of it arriving in our systems, rather than waiting until after the UTC day ends.
Posted Feb 03, 2020 - 11:25 PST
This incident affected: Export API.