Meta API Latency

Incident Report for Branch

Resolved

Latency has now returned to normal.
Posted Mar 05, 2026 - 11:20 PST

Update

We are seeing a decrease in the latency and will continue to monitor.
Posted Mar 05, 2026 - 10:09 PST

Monitoring

We are currently observing severe latency with the Meta Graph API. This is resulting in a temporary loss of real-time reporting data.

We have alerted Meta and are monitoring the situation closely and will provide updates as they become available.
Posted Mar 05, 2026 - 08:34 PST