Services Degraded: Missing Dashboard Features

Incident Report for Branch

Resolved

The identified issue has been resolved, and services are now restored. You should see the dashboard features available again.
Posted Mar 13, 2026 - 02:10 PDT

Investigating

Our Engineering team is currently working to resolve an issue where some customers are reporting missing features from their dashboard. We appreciate your patience as we work to restore full functionality as quickly as possible.
Posted Mar 12, 2026 - 23:59 PDT
This incident affected: Dashboard.