Creating App Issue
Incident Report for Branch
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 29, 2019 - 10:25 PDT
Investigating
There is known issue creating new apps which also affects new user signups. Engineering is investigating.
Posted 3 months ago. Apr 29, 2019 - 02:11 PDT
This incident affected: Dashboard.