Intermittent New User Creation and Scheduled Reports Errors

Incident Report for Branch

Resolved

Our Engineers have identified the root cause of the intermittent issues and it should now be resolved. We will continue to monitor.
Posted Apr 05, 2023 - 16:21 PDT

Identified

Our engineers have identified an issue which is impacting creating new users, forgot password functionality, and sending scheduled reports. We are currently investigating.
Posted Apr 05, 2023 - 12:08 PDT
This incident affected: Dashboard.