Notice: Branch is Unaffected by the CrowdStrike Software Update
Incident Report for Branch
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 08:14 PDT
Monitoring
Branch is not affected by the CrowdStrike software update. This update is causing widespread issues for many IT teams worldwide, particularly with Windows systems. While we may experience challenges in reaching and interacting with customers who use Microsoft services like Teams, all of Branch's backend services and systems remain unaffected. We are monitoring the situation closely and will reach out should anything change.
Posted Jul 19, 2024 - 09:06 PDT