Attribution Pipeline Delay
Incident Report for Branch
Resolved
Our team has identified the root cause and has applied a fix. Analytics are back to real-time.
Posted Jun 06, 2022 - 22:39 PDT
Investigating
We're experiencing some delays with our attribution pipeline. We'll update here once analytics are back to real-time.
Posted Jun 06, 2022 - 15:53 PDT