We are observing high failure rate on Universal Email Links from 3:20 PM PST. Our Engineering team is working to fix this issue.
Incident Report for Branch
Resolved
We rolled back a bad deploy that caused this issue. All links are back up and operational as of 4.15 PM PT
Posted Mar 06, 2020 - 16:17 PST
Investigating
We are currently investigating this issue.
Posted Mar 06, 2020 - 16:13 PST
This incident affected: Link Redirection.