Increased latency on Branch links
Incident Report for Branch
Resolved
As of 10:20am PT, all systems were returned to normal. We saw increased latency on some links, and once we diagnosed the issue we quickly restored latencies back to regular levels.
Posted 6 months ago. Mar 26, 2019 - 10:54 PDT
Investigating
Starting at at 8:54am PT, we began seeing increased latency and timeouts on Branch Links. Our team is working to restore regular service.
Posted 6 months ago. Mar 26, 2019 - 09:36 PDT
This incident affected: Link Redirection and Deep Linking.