Increased latencies from Facebook SAN Partner

Incident Report for Branch

Resolved

Meta has resolved disruptions to their attribution claim pipelines as of Saturday March 15th 04:10 PM Pacific Time. These disruptions caused delays in claims received from Meta, resulting in attribution loss and potential misattributions. We have resumed our attribution pipelines back to normal. Latency previously observed has subsided, however we will continue to monitor our services.
Posted Mar 15, 2025 - 20:30 PDT

Identified

Our engineering team has identified high latency response times from the Facebook SAN API, which is impacting attribution accuracy and reporting within our platform. The increased response time is leading to lower-than-expected attributions to Facebook and potential misattributions to other channels due to delayed postbacks from FB.

Due to high latency, we have also disabled SAN Deferred Deep Linking, which will impact deep linking and attribution for events relying on SAN calls.
Posted Mar 15, 2025 - 07:38 PDT

Investigating

Our engineering team has identified a high latency in responses from Facebook SAN API resulting in a delay to the attribution pipeline. We have reached out to Facebook and are currently investigating.
Posted Mar 14, 2025 - 23:08 PDT