Dashboard Service Degradation
Incident Report for Branch
Resolved
Dashboard services have stabilized and returned to normal.
Posted Sep 20, 2024 - 03:43 PDT
Investigating
We are observing an issue with our Dashboard Service. Users might see latency with the Dashboard loading or encounter a blank page while trying to access the Branch Dashboard. Our Engineering Teams are actively Investigating.
Posted Sep 20, 2024 - 02:56 PDT
This incident affected: Dashboard.